Manual repayment of Capital advances is temporarily unavailable for R Series merchants in the US

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Feb 12, 2025 - 21:14 EST

Update

R-Series merchants in the US with Capital Advances are unable to make manual repayments in the app
Posted Feb 12, 2025 - 16:29 EST

Update

We are continuing to investigate this issue.
Posted Feb 12, 2025 - 16:29 EST

Investigating

We are currently investigating this issue.
Posted Feb 12, 2025 - 10:24 EST