Lightspeed Payments
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Nov 22, 2020 - 16:35 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 22, 2020 - 15:54 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 22, 2020 - 15:39 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 22, 2020 - 15:09 EST
Investigating
We are currently investigating an issue affecting merchants using Lightspeed Payments. A dedicated team is investigating the issue.
Posted Nov 22, 2020 - 13:57 EST
This incident affected: Lightspeed Payments.