Reduced availability support
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Oct 16, 2024 - 03:03 EDT
Identified
Due to an external issue, we are currently experiencing reduced response times for our phone, chat, and email support services. We appreciate your patience during this time.
Posted Oct 15, 2024 - 11:46 EDT
This incident affected: Lightspeed Support (Phone Support, Chat Support, Email Support).