Lightspeed Payment Retail, terminal fail to update
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved
Posted Aug 23, 2024 - 05:35 EDT
Update
We have identified the issue is with an update that we have since rolled back. For those still affected, please power cycle (restart) your terminal instead of factory resetting it. This should now restore functionality without the need to reinstall any software.
Posted Aug 21, 2024 - 10:56 EDT
Identified
We have identified the issue is with an update that we have since rolled back. For those still affected, please power cycle (restart) your terminal instead of factory resetting it. This should now restore functionality without the need to reinstall any software.
Posted Aug 21, 2024 - 10:32 EDT
Investigating
Merchants experiencing the 'Failed to download updates' error with code I1-I on their WisePOS E terminals. We are investigating, factory resetting the terminal by pressing the two blue buttons on the side for several seconds seems to fix the issue. Once it is done please repair the terminal to reinstall the proper terminal software.
Posted Aug 21, 2024 - 05:14 EDT
This incident affected: Lightspeed Retail (R-Series) (Integrated Payments) and Lightspeed Retail (X-Series) (Payments).