O-Series Insights: Data sync delayed from 2PM AEST

Incident Report for Lightspeed - Status Page

Resolved

Data should now be up to date
Posted Nov 19, 2025 - 00:07 EST

Identified

The issue has been identified and a fix is being remedied.
However be aware that Insights currently does not have up to date data from 2:00PM 19th November onwards.

Our team are backfilling this data as we speak.
Posted Nov 18, 2025 - 23:50 EST
This incident affected: Lightspeed Restaurant (O-Series) (Insights).