Lightspeed Retail
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted May 30, 2020 - 18:03 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 30, 2020 - 15:07 EDT
Investigating
We are currently investigating an issue affecting the performance of merchants using Lightspeed Retail. A dedicated team is investigating the issue.
Posted May 30, 2020 - 14:50 EDT
This incident affected: Lightspeed Retail (Retail POS, Retail API).