Lightspeed Restaurant (O-Series) - Updates & New Improvements 12.14.0

Scheduled for Aug 4, 01:00 - 02:00 EDT

Scheduled

We're excited to announce another update to your POS that will bring improved efficiency and stability.

Update Time: Tuesday, August 4 at 15:00 AEST
Update Process: No need to interrupt your sales. Your POS will automatically update after 15:00 AEST.

NEW
- Get ahead of the 1 October ban on card surcharges with the new Menu Pricing Assistant. Instead of re-pricing every product by hand, set your card rate and rounding preferences and the assistant suggests updated prices across your products and price lists, ready to review, schedule, and apply in bulk.

IMPROVED
- Added preparation time syncing to Doshii, so delivery and online-ordering ETAs stay accurate, including when you temporarily adjust prep time from the POS.
- Updated Lightspeed Loyalty SMS messages to show "Lightspeed" as the sender instead of a phone number.
- Added the Company ID to webhook and callback payloads, so integrations can route events more easily.

RESOLVED
- Fixed an issue where a bill split across two or more cards printed a receipt for the first card only, so the customer did not get a receipt for every card charged.
- Fixed an issue where a card surcharge on a Smart Hospo terminal payment (via Doshii) was not shown on the POS or the customer receipt.
- Fixed an issue where AI Menu Importer created option set choices as separate products instead of options.
- Fixed an issue where reordering an option set's choices did not send the expected webhook update for online products.
- Fixed an issue where a completed online order could report a course as still pending instead of called.
- Fixed an issue where the AI feedback icon was missing on the Printers page in Back Office.

IN CASE YOU MISSED IT
Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral!
See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Jul 30, 2026 - 02:49 EDT
This scheduled maintenance affects: Lightspeed Restaurant (O-Series) (POS, Back Office).