The issue where partial refunds via Lightspeed Payments on O-Series were processing as full refunds has been resolved following a hotfix.
All partial refunds are now processing correctly, and no further action is required from merchants.
Posted Sep 03, 2025 - 03:51 EDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 03, 2025 - 03:20 EDT
Update
We will be deploying a hotfix to resolve the issue where partial refunds via Lightspeed Payments on O-Series are processing as full refunds.
The fix is expected to be live and the issue resolved by 18:00 AEST.
Posted Sep 03, 2025 - 03:16 EDT
Identified
We have identified the cause of the issue where partial refunds via Lightspeed Payments on O-Series are processing as full refunds. Our team is actively working on a fix.
Workaround If you need to process a partial refund in the meantime, please refund to Cash instead of Lightspeed Payments.
We will provide further updates as we progress towards resolution.
Posted Sep 03, 2025 - 00:34 EDT
Investigating
We have identified an issue where partial refunds processed through Lightspeed Payments on O-Series are incorrectly refunding the full payment amount.
Impact All O-Series merchants using Lightspeed Payments are affected when performing partial refunds via POS.
Workaround If you need to process a partial refund, please refund to Cash instead of Lightspeed Payments until this issue is resolved.
We are working on a fix and will provide updates as they become available.
Posted Sep 03, 2025 - 00:21 EDT
This incident affected: Lightspeed Restaurant (O-Series) (POS, Lightspeed Payments).