Elevated Payments Errors Detected
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Dec 14, 2019 - 18:05 EST
Update
The error rates have recovered to normal level. Some merchants may need to disconnect/reconnect their terminal from the power source to achieve full recovery.
Posted Dec 14, 2019 - 18:00 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 14, 2019 - 17:12 EST
Update
We are observing improvements in our error rate. We are continuing to investigate the issue with our 3rd party partner and will keep you updated as more information becomes available.
Posted Dec 14, 2019 - 16:49 EST
Update
Our third-party partner continues to experience a technical issue. Our technical teams are engaged and are troubleshooting the incident with the partner. Further updates will be provided as additional information becomes available.
Posted Dec 14, 2019 - 16:11 EST
Update
We are continuing to work on a fix for this issue.
Posted Dec 14, 2019 - 15:40 EST
Identified
We have identified the cause of the Lightspeed Payments issue and our engineers are working on a solution. We will update you as more information becomes available.
Posted Dec 14, 2019 - 15:39 EST
Investigating
We have identified an issue with Lightspeed Payments. A dedicated team is researching the issue. We will update you as more information becomes available.
Posted Dec 14, 2019 - 15:33 EST
This incident affected: Lightspeed Restaurant (K-Series) (Lightspeed Payments).