Lightspeed Restaurant (O-Series) - Updates & New Improvements 12.10.0

Scheduled for Jun 9, 01:00 - 02:00 EDT

Scheduled

We're excited to announce another update to your POS that will bring improved efficiency and stability.

Update Time: Tuesday, June 9 at 15:00 AEST
Update Process: No need to interrupt your sales. Your POS will automatically update after 15:00 AEST.

IMPROVED
- Added a default-on "Hide deleted options" checkbox to Back Office report filters, hiding deleted categories, registers, users, sites, amongst other options from every filter dropdown.
- Improved the Site and Company timezone picker with clearer city-based labels, Australia and New Zealand grouped first, and additional timezones including Norfolk Island, Lord Howe Island, and Chatham Islands.

RESOLVED
- Fixed an issue where print errors did not offer a reprint option when Parallel Printing was turned off.
- Fixed an issue where a small refund could leave a customer's loyalty credit balance inconsistent.
- Fixed an issue where the Back Office Suppliers tab counted and paged through non-purchased products, producing uneven page sizes and an inflated total.
- Fixed an issue where cancelling or exiting a split-by-product card payment incorrectly reported the order as deleted in Insights.
- Fixed an issue where an item could be removed from an order without approval when changes via the permission override feature were waiting to be approved.
- Fixed an issue where a white band appeared along the bottom of the screen on iPhones and iPads with a home-indicator safe area.
- Fixed an issue where emailed On-Account invoice PDFs with 50 or more line items squashed every line onto a single unreadable page.
- Fixed an issue where updating a customer's loyalty reference on POS did not send a customers/updated webhook to connected integrations.
- Fixed an issue where some customer errors on the Reservations API returned a server error instead of a clear validation error.

IN CASE YOU MISSED IT
Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral!
See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Jun 03, 2026 - 02:00 EDT
This scheduled maintenance affects: Lightspeed Restaurant (O-Series) (POS, Back Office).