Error with documentation upload for Lightspeed Payments and Capital applications

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Oct 02, 2025 - 10:12 EDT

Investigating

We are currently investigating an issue related to document uploads for Lightspeed Payments and Capital applications. This also impacts the ability to upload documentation for bank account updates and legal entity changes for Lightspeed Payments accounts. We will keep you posted with updates as they come. Thanks for your patience.
Posted Oct 02, 2025 - 07:45 EDT
This incident affected: Lightspeed Restaurant (G-Series) (Lightspeed Payments), Lightspeed Restaurant (L-Series) (Lightspeed Payments), Lightspeed Retail (R-Series) (Integrated Payments), Lightspeed Restaurant (K-Series) (Lightspeed Payments), Lightspeed Retail (X-Series) (Payments), and Lightspeed Restaurant (O-Series) (Lightspeed Payments).