Lightspeed Restaurant (O-Series) - Updates & New Improvements 12.17.0

Scheduled for Sep 14, 01:00 - 02:00 EDT

Scheduled

Update Time: Monday, September 14 at 15:00 AEST
Update Process: Your POS will automatically update after 15:00 AEST.

IMPROVED
- Improved order syncing when printing subtotal receipts from the POS to reduce the risk of incorrect receipt totals when an order is open on multiple registers.
- Simplified access to the Inventory stock locations page. Staff with the Stocktaking permission no longer require the Site Products permission and access is now available on all POS plans.

RESOLVED
- Fixed an issue where Lightspeed Payments Pay-at-Table forgot the original split quantity after the first payment and prompted to re-split the remainder.
- Fixed an issue where cancelling a Lightspeed Payments card payment could leave POS stuck on the cancellation animation.
- Fixed an issue where the POS could freeze during Lightspeed Payments transactions during temporary network disconnections.
- Fixed an issue where POS orders could become stuck when checking out if Enforce Order Note and Promotions are both enabled.
- Fixed an issue where takings could fail to load when reconciling with a large number of open orders present.
- Fixed an issue where products marked as unavailable in POS appeared as available in Doshii connected online ordering integrations on a site's first connection.
- Fixed an issue where the product keyword search on POS could omit matching products from a very large product catalogue.

MORE PRODUCT UPDATES
For the latest feature announcements, visit Lightspeed Product Updates.

IN CASE YOU MISSED IT
Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral!
See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Sep 10, 2026 - 02:50 EDT
This scheduled maintenance affects: Lightspeed Restaurant (O-Series) (POS, Back Office).