Unable to take online payments with Order Anywhere
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved
Posted Jun 10, 2024 - 10:13 EDT
Identified
We identified the root cause and try to fix the issue
Posted Jun 10, 2024 - 08:02 EDT
This incident affected: Lightspeed Restaurant (K-Series) (Order Anywhere).