Degraded performance of integrated payment processing
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted May 12, 2022 - 13:39 EDT
Update
Performance has returned to normal and we are continuing to monitor
Posted May 12, 2022 - 13:26 EDT
Monitoring
Integrated payment processing performance is improving and returning to normal
Posted May 12, 2022 - 13:20 EDT
Investigating
We are currently investigating an issue affecting integrated payments on Lightspeed Retail (R Series)
Posted May 12, 2022 - 13:13 EDT
This incident affected: Lightspeed Retail (R-Series) (Integrated Payments) and Lightspeed Restaurant (K-Series) (Lightspeed Payments).