Lightspeed Payments - Degraded Performance
Incident Report for Lightspeed - Status Page
Resolved
The issue with Lightspeed Payments has been resolved. Transactions are now being processed normally.
Posted Jun 04, 2020 - 12:33 EDT
Update
We are continuing to monitor for any further issues.
Posted Jun 04, 2020 - 11:33 EDT
Monitoring
We have implemented a fix and will continue to monitor the situation.
Posted Jun 04, 2020 - 11:32 EDT
Identified
We have identified the cause of the Lightspeed Payments issue and a dedicated team of engineers is working on a solution.
Posted Jun 04, 2020 - 11:28 EDT
Update
We are continuing to investigate the issue. The connectivity issue manifests as an error in your POS as "Please Contact Support - Enable to discover Readers". Please wait a few minutes and initiate the transaction again.
Posted Jun 04, 2020 - 11:11 EDT
Investigating
Some merchants using the P400 terminal may experience connectivity issues with Lightspeed Payments. Our team is investigating the issue.
Posted Jun 04, 2020 - 10:35 EDT
This incident affected: Lightspeed Payments.