Issue with Lightspeed Payments
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Aug 03, 2023 - 18:40 EDT
Monitoring
A fix has been implemented for Lightspeed Payments customers using K-Series and L-Series with standalone terminals, as well as affected G-Series customers. We are monitoring the results and will proactively reach out to any customers that may be affected.

If you have experienced unexpected behaviour from your Lightspeed Payment terminal during this time, please contact our 24x7 Support team.
Posted Aug 03, 2023 - 17:55 EDT
Update
For customers using K Series, L Series, and G Series in Europe: some customers using Lightspeed Payments with Adyen may be experiencing issues with their payment terminal.

If you are a G-Series customer using Lightspeed Payments with Adyen, please contact Support immediately.

If you are a K-Series or L-Series customer using a terminal in standalone mode with Lightspeed Payments with Adyen, please contact Support immediately.
Posted Aug 03, 2023 - 14:18 EDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 03, 2023 - 12:19 EDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 03, 2023 - 12:14 EDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 03, 2023 - 12:10 EDT
Identified
For customers using K-Series, L-Series, and G-Series in Europe: some customers using Lightspeed Payments with Adyen may be experiencing issues with their payment terminal.

If you are a G-Series customer using Lightspeed Payments with Adyen, please contact Support immediately.

If you are a K-Series or L-Series customer using a terminal in standalone mode with Lightspeed Payments with Adyen, please contact Support immediately.
Posted Aug 03, 2023 - 11:46 EDT
This incident affected: Lightspeed Restaurant (G-Series) (Lightspeed Payments), Lightspeed Restaurant (L-Series) (Lightspeed Payments), and Lightspeed Restaurant (K-Series) (Payments, Lightspeed Payments).