Lightspeed Retail (X-Series) - Unable to access Outlet and Registers Setup Page

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Sep 19, 2022 - 13:04 EDT

Investigating

We're investigating an issue preventing merchants from being able to access the Outlet and Registers Setup page. We'll send updates as they arise, thanks for your patience.
Posted Sep 19, 2022 - 12:42 EDT
This incident affected: Lightspeed Retail (X-Series) (Setup).