New POS Version causes App crashes

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 03:24 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 26, 2025 - 05:00 EDT

Investigating

We are aware of an issue impacting a new version of the POS (25.34.0), where we identified multiple app crashes. Try not to update to the newest app version. We are working on a fix.
Posted Aug 26, 2025 - 03:24 EDT
This incident affected: Lightspeed Restaurant (K-Series) (POS).