Lightspeed Payment (L-Series and R-Series)

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Jun 18, 2025 - 16:03 EDT

Monitoring

A fix has been implemented and we are monitoring the situation
Posted Jun 18, 2025 - 15:45 EDT

Update

[R-Series] Merchants experiences issues can also process transactions in Standalone mode until the issue is resolved https://retail-support.lightspeedhq.com/hc/en-us/articles/27640682216731-Processing-payments-in-standalone-and-offline-mode
Posted Jun 18, 2025 - 15:32 EDT

Identified

We have identified the cause of the Lightspeed Payments issue and a dedicated team of engineers is working on a solution.
Posted Jun 18, 2025 - 15:26 EDT

Update

We are continuing to investigate this issue.
Posted Jun 18, 2025 - 15:14 EDT

Investigating

We are currently investigating an issue affecting merchants using Lightspeed Retail. A dedicated team is investigating the issue.
Posted Jun 18, 2025 - 14:58 EDT
This incident affected: Lightspeed Restaurant (L-Series) (Lightspeed Payments) and Lightspeed Retail (R-Series) (Integrated Payments).