Lightspeed Retail (X-Series) - Stores are unavailable
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Sep 18, 2024 - 01:11 EDT
Identified
The issue has been identified and a fix was implemented
Posted Sep 18, 2024 - 01:07 EDT
Investigating
We are investigating reports of stores not accessible to retailers. We'll keep you updated as we find out more.
Posted Sep 18, 2024 - 01:02 EDT
This incident affected: Lightspeed Retail (X-Series) (Retail POS).