Delays - Product processing / Lagging

Incident Report for Lightspeed - Status Page

Resolved

This incident is resolved now
Posted Sep 25, 2025 - 20:00 EDT

Investigating

We're investigating an issue with delays in catalog processing, preventing products from showing up after their creation to Lightspeed (X-Series) retailers and will keep you posted with updates as they come. Thanks for your patience.
Posted Sep 25, 2025 - 06:34 EDT
This incident affected: Lightspeed Retail (X-Series) (Products).