Restaurant O-Series: Support Phone

Incident Report for Lightspeed - Status Page

Resolved

Our telecommunications provider has been able to restore their services.
Posted Jul 28, 2024 - 22:56 EDT

Identified

An issue with our telecommunications provider is impacting phone services for our Technical Support lines. Neither customers nor service agents are able to hear each other.

Our upstream provider is currently investigating this issue.

Our team remain online via chat here.
Posted Jul 28, 2024 - 20:30 EDT
This incident affected: Lightspeed Restaurant (O-Series) (Support (Phone/Email/Live Chat)).