Restaurant O-Series: Manual POS Sync failed with "Unable to download orders"

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 04:43 EDT

Monitoring

A fix has been deployed and we are monitoring results
Posted Mar 16, 2026 - 16:26 EDT

Investigating

We are getting reports that users performing a manual sync will receive an error message saying "Unable to download orders".
However orders themselves appear to be getting updated as expected.

Our team have found the cause for this error message and are currently working on a fix.
Posted Mar 16, 2026 - 16:09 EDT
This incident affected: Lightspeed Restaurant (O-Series) (POS, Produce).