Lightspeed Payment - Payout Schedule
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Apr 11, 2023 - 15:25 EDT
Monitoring
Dear Customer,
We wanted to inform you that there will be a delay in receiving your payouts due to Easter holidays. Since banks are closed on Good Friday and Easter Monday, payouts scheduled will be delayed to the following business day.
Enjoy the Holidays
Posted Apr 06, 2023 - 17:52 EDT
This incident affected: Lightspeed Restaurant (K-Series) (Lightspeed Payments).