Phone Support unavailable in some regions in North America
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Aug 05, 2024 - 11:54 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 05, 2024 - 11:36 EDT
Update
The issue has been identified and a fix is being implemented. Please contact us through chat in the meantime if you’re unable to reach us by phone
Posted Aug 05, 2024 - 11:27 EDT
Identified
The issue has been identified and a fix is being implemented. Please contact us through chat in the meantime if you’re unable to reach us by phone.
Posted Aug 05, 2024 - 11:26 EDT
This incident affected: Lightspeed Support (Phone Support).