Lightspeed Payments - Pay at Table Issue
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Apr 10, 2023 - 14:47 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 09, 2023 - 17:00 EDT
Investigating
Some customers have reported an issue with processing integrated transactions on their Lightspeed Payments terminal due to a Pay@Table screen appearing on their terminal interface.

We have escalated the issue to internal teams who are working to get the issue resolved as soon as possible.

If your Lightspeed Payments terminal is experiencing the issue, please reach out to support via chat, phone or email.

We will be posting further updates on the issue here as they come to light and apologise for the inconvenience this has caused.
Posted Apr 08, 2023 - 23:12 EDT
This incident affected: Lightspeed Restaurant (K-Series) (Payments, Lightspeed Payments).