Phone services not available
Incident Report for Lightspeed - Status Page
Resolved
This issue is resolved, and our phone queues remain operational as usual.
Posted Nov 20, 2024 - 09:09 EST
Monitoring
An outage of our third-party service provider has resulted in our phone lines being temporarily unavailable. The service provider is investigating the issue.

Please contact us through the chat option in your back office if you require Support.
Posted Nov 20, 2024 - 08:43 EST
This incident affected: Lightspeed Support (Phone Support).