Payout delays in Europe
Incident Report for Lightspeed - Status Page
Resolved
We have received confirmation that several merchants received their missing payouts as of yesterday.
We understand how important it is to access your funds. Thank you for your patience with us as we worked to resolve this external issue.
Posted Aug 09, 2024 - 09:21 EDT
Monitoring
Crédit Mutuel has informed us that the EUR payout delay was caused by an internal technical glitch. The issue is currently being fixed, and merchants will start receiving the delayed payouts gradually. Other affected banks (such as CIC & Beobank) may be experiencing a similar glitch. Therefore, we advise affected customers to reach out to their bank representative for further assistance.
We appreciate your patience as we continue to work to address this matter.
Posted Aug 08, 2024 - 06:31 EDT
Identified
We are currently experiencing settlement delays with several banks, including Credit Mutuel, CIC, Beobank, and their associated institutions. This issue has been escalated to the European Banking Authority for an urgent resolution.
We appreciate your patience as we work diligently to address this matter. We understand the critical importance of accessing your funds for your daily business operations.
Posted Aug 07, 2024 - 12:07 EDT
Investigating
We're currently investigating an issue where a subset of merchants based in Europe are experiencing payout delays.
We understand how important it is to have access to your funds, and our team is keeping in touch with our banking partners as they work on a fix. Thank you for your patience with us as we work to resolve this issue
Posted Aug 07, 2024 - 04:50 EDT
This incident affected: Lightspeed Restaurant (L-Series) (Lightspeed Payments) and Lightspeed Restaurant (K-Series) (Lightspeed Payments).