Downgraded Performance in Reports and Financial API

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Feb 25, 2025 - 09:11 EST

Update

The issue was fixed and the performance of reporting and financial API is back to normal
Posted Feb 25, 2025 - 09:10 EST

Identified

The issue has been identified and we are currently working on a fix
Posted Feb 20, 2025 - 21:27 EST

Investigating

We are currently investigating an issue causing degraded performance in Reports and the Financial API. Users may experience slower response times or delays in report generation and financial data retrieval.
Posted Feb 19, 2025 - 17:05 EST
This incident affected: Lightspeed Restaurant (K-Series) (Back Office - Reporting).