Europe only: Instant payout and scheduled same-day payout unavailable

Incident Report for Lightspeed - Status Page

Resolved

Instant payouts in EUR to European bank accounts are now fully operational. There was no impact on other payout methods.
Posted May 20, 2026 - 03:12 EDT

Investigating

Europe only: Instant Payout and Scheduled Same Day Payout to EUR bank accounts are currently unavailable due to an external issue affecting SEPA Instant. We started seeing impact on 19 May at 11:00 CET. Standard payouts to EUR bank accounts are processing normally. We will share another update as soon as we have more information
Posted May 19, 2026 - 12:00 EDT
This incident affected: Lightspeed Restaurant (G-Series) (Lightspeed Payments), Lightspeed Restaurant (L-Series) (Lightspeed Payments), Lightspeed Retail (R-Series) (Integrated Payments), Lightspeed Restaurant (K-Series) (Lightspeed Payments), and Lightspeed Retail (X-Series) (Payments).