Lightspeed Payments - Partial Payout delay for Hospitality Merchants

Incident Report for Lightspeed - Status Page

Resolved

The technical issue causing the partial delays have been resolved, and all delayed payments have been paid out.
We will continue monitoring and provide a new update if required.
Thank you for your patience with us.
Posted Mar 25, 2025 - 05:36 EDT

Identified

Starting March 22 we have identified an external technical issue resulting in a delay of up to 6 hours between when a sale is made and when the available Payment has settled. Due to that issue, a subset of Lightspeed Payments users will experience partial settlement delays.
We understand how important it is to have access to your funds, and our team is keeping in touch with our banking partners as they work on a fix. Please note that payment processing is not impacted.
Thank you for your patience with us as we work to resolve this issue
Posted Mar 24, 2025 - 10:40 EDT
This incident affected: Lightspeed Restaurant (G-Series) (Lightspeed Payments), Lightspeed Restaurant (L-Series) (Lightspeed Payments), Lightspeed Restaurant (K-Series) (Lightspeed Payments), and Lightspeed Restaurant (O-Series) (Lightspeed Payments).