Lightspeed Retail (X-Series) - New products not showing in Catalog/Sell screen
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved. We apologised for any inconvenience it might have caused you.
Posted Feb 28, 2024 - 11:40 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 28, 2024 - 10:47 EST
Identified
The issue has been identified and we're working on implementing a fix as soon as possible. Thank you for your patience.
Posted Feb 28, 2024 - 10:19 EST
Investigating
We are currently investigating an issue affecting new products not showing in the Catalog and Sell Screen, and updating inventory for new products not working.
Posted Feb 28, 2024 - 08:53 EST
This incident affected: Lightspeed Retail (X-Series) (Products).