Lightspeed Retail (X-Series) - Errors when accessing Lightspeed E-Series

Incident Report for Lightspeed - Status Page

Resolved

The issue with E-Series has been resolved, thank you for your patience.
Posted May 08, 2025 - 10:38 EDT

Investigating

The team is working hard to resolve an issue with Lightspeed E-Series and will keep you informed on status changes as they come. Thanks for your patience, we apologize for any inconvenience this has caused.

You can also follow the E-Series Status Page for more information: https://status.ecwid.com/
Posted May 08, 2025 - 09:26 EDT
This incident affected: Lightspeed Retail (X-Series) (Retail POS, Retail POS for iPadOS).