X-Series - Users unable to log in (UK region)

Incident Report for Lightspeed - Status Page

Resolved

Retailers in the UK are experiencing login problems due to global issues with ISP providers in the region.
Posted Sep 24, 2025 - 10:59 EDT

Identified

Retailers in the UK are experiencing login problems due to global issues with ISP providers in the region.
Posted Sep 24, 2025 - 08:40 EDT

Investigating

Some customers are reporting that they are unable to load the POS. We're currently investigating this.
Posted Sep 24, 2025 - 06:18 EDT
This incident affected: Lightspeed Retail (X-Series) (Retail POS, Retail POS for iPadOS).