Investigating Payout Delays for Australia

Incident Report for Lightspeed - Status Page

Resolved

Our team has received confirmation that the payouts have been successfully processed and are showing a status of Completed without any issues. Based on these confirmations, we are closing this incident as resolved.
Posted Dec 04, 2025 - 20:20 EST

Investigating

The Lightspeed Payments team is currently investigating an active issue regarding a possible payout delay starting on the 3rd of December.
Posted Dec 04, 2025 - 07:37 EST
This incident affected: Lightspeed Restaurant (K-Series) (Payments) and Lightspeed Restaurant (O-Series) (Lightspeed Payments).