Payouts for our Australian retail merchants from April 3rd are delayed

Incident Report for Lightspeed - Status Page

Resolved

Australian merchants confirmed that the payout expected on the 3rd of April was received on the 8th of April.
Posted 25 days ago. Apr 08, 2025 - 07:51 EDT

Identified

Retail Australia: Payouts intended to arrive on April 3rd are delayed. We now expect them to arrive on Tuesday, April 8th.
Posted 29 days ago. Apr 04, 2025 - 08:38 EDT

Update

We are continuing to investigate this issue.
Posted 29 days ago. Apr 04, 2025 - 08:36 EDT

Update

Incident not applicable for this serie
Posted 29 days ago. Apr 04, 2025 - 08:33 EDT

Update

Incident not applicable for this serie
Posted 29 days ago. Apr 04, 2025 - 08:29 EDT

Investigating

Retail Australia: Payouts intended to arrive on April 3rd are delayed.
Posted 29 days ago. Apr 04, 2025 - 04:32 EDT
This incident affected: Lightspeed Restaurant (K-Series) (Lightspeed Payments).
Français (Canada)
Powered by Localize
English