Lightspeed Payments
Incident Report for Lightspeed - Status Page
Resolved
The third-party partner has resolved the issue. Transactions are now being processed normally.
Posted Jun 17, 2022 - 18:56 EDT
Update
The issue has been resolved.
Posted Jun 17, 2022 - 18:52 EDT
Update
We are continuing to investigate this issue.
Posted Jun 17, 2022 - 18:51 EDT
Update
The issue has been resolved.
Posted Jun 17, 2022 - 18:43 EDT
Update
We are continuing to investigate this issue.
Posted Jun 17, 2022 - 17:53 EDT
Update
We are continuing to investigate this issue.
Posted Jun 17, 2022 - 17:52 EDT
Update
We are experiencing technical issues with one of our third-party payment providers, specifically, merchants using the MX915, IPP320, and ISMP4. We are monitoring the situation. Thank you for your patience.
Posted Jun 17, 2022 - 17:45 EDT
Investigating
We are experiencing technical issues with one of our third-party payment providers, specifically, merchants using the MX915, IPP320, and ISMP4. We are monitoring the situation. Thank you for your patience.
Posted Jun 17, 2022 - 17:10 EDT
This incident affected: Lightspeed Retail (R-Series) (Retail POS, Integrated Payments) and Lightspeed Restaurant (K-Series) (Lightspeed Payments).