Lightspeed K-series: App becomes unresponsive after screen off post-payment confirmation

Incident Report for Lightspeed - Status Page

Resolved

We have released a fix for this issue in version 26.24.1. Please update your Lightspeed K-Series app through the App Store to resolve the problem.
Posted Jun 18, 2026 - 03:22 EDT

Identified

Update: We have successfully identified the issue. We are working to deploy a fix and expect version 26.24.1 to be available on the App Store as soon as possible.
Posted Jun 17, 2026 - 11:34 EDT

Investigating

We are currently investigating an issue where the Lightspeed K-Series app becomes unresponsive on iOS devices when the iPhone is locked (screen turned off) after a payment has successfully completed.

Workaround: Close and restart the app to restore functionality.
Posted Jun 17, 2026 - 03:48 EDT
This incident affected: Lightspeed Restaurant (K-Series) (Lightspeed Payments).