External issue with Internet Service Provider BT (UK based)

Incident Report for Lightspeed - Status Page

Resolved

BT's incident has been resolved.
Posted Nov 28, 2025 - 06:31 EST

Monitoring

We are observing an external issue with BT experiencing issues with internet connections

Pages unable to load, slowness, and other systems may be impacted.
We are monitoring the situation closely and will provide updates as further information becomes available.
Posted Nov 28, 2025 - 06:06 EST

Investigating

We are observing an external issue with BT experiencing issues with internet connections

Pages unable to load, slowness, and other systems may be impacted.
We are monitoring the situation closely and will provide updates as further information becomes available.
Posted Nov 28, 2025 - 05:51 EST
This incident affected: Lightspeed Retail (X-Series) (Retail POS, Retail POS for iPadOS).