Lightspeed Payments
Incident Report for Lightspeed - Status Page
Resolved
The third-party partner has resolved the issue. Transactions are now being processed normally.
Posted May 11, 2020 - 13:11 EDT
Monitoring
We have implemented a fix and will continue to monitor the situation.
Posted May 11, 2020 - 13:01 EDT
Identified
We have identified the cause of the Lightspeed Payments issue and a dedicated team of engineers is working on a solution.
Posted May 11, 2020 - 12:52 EDT
This incident affected: Lightspeed Restaurant (K-Series) (Lightspeed Payments).