Lightspeed Retail (X-Series) - Delay in processing sales history, products, inventory and customer updates

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Nov 07, 2022 - 21:33 EST

Monitoring

A fix has been implemented and we are currently monitoring the situation. We’re sorry for the inconvenience.
Posted Nov 07, 2022 - 19:08 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 07, 2022 - 18:58 EST

Investigating

We are noticing that there is some delay in processing sales history, products, inventory and customer related updates. We are currently investigating this issue.
Posted Nov 07, 2022 - 18:16 EST
This incident affected: Lightspeed Retail (X-Series) (Customer Management, Inventory, Products, Reporting, Retail POS, Sales History).