Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 01, 2025 - 23:00 EST
Scheduled
We're excited to announce another update to your POS that will bring improved efficiency and stability.
Update Time: Tuesday, December 2 at 15:00 AEDT Update Process: No need to interrupt your sales. Your POS will automatically update after 15:00 AEDT.
IMPROVED - Course reordering in Back Office is now more intuitive, placing each course exactly where you move it within the Courses setup. - Gift Card search in Back Office now supports partial matches for faster, more accurate results. - You can now reprint the latest Gift Card top-up or transfer receipt directly from the POS Gift Card modal. - Online ordering enable/disable actions in POS now sync correctly to Doshii, ensuring connected online stores stop or resume sending orders as expected.
RESOLVED - Pay at Table payments now complete orders more reliably, preventing duplicate payment attempts.
IN CASE YOU MISSED IT Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral! See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Nov 30, 2025 - 20:30 EST
This scheduled maintenance affected: Lightspeed Restaurant (O-Series) (POS, Back Office).