[X-Series] Unable to reprint receipts from Sales History

Incident Report for Lightspeed - Status Page

Resolved

We have rolled out a fix for the issue where receipts cannot be reprinted from the Sales History. Thank you for your patience.
Posted Feb 20, 2025 - 07:31 EST

Identified

We are currently looking into an issue where receipts cannot be reprinted from the Sales History.
Posted Feb 20, 2025 - 07:25 EST

Update

We are currently looking into an issue where receipts cannot be reprinted from the Sales History.
Posted Feb 20, 2025 - 07:17 EST

Investigating

We are currently looking into an issue where receipts cannot be reprinted from the Sales History.
Posted Feb 20, 2025 - 07:16 EST
This incident affected: Lightspeed Retail (X-Series) (Sales History).