Lightspeed Payments (K-Series): Some CA merchants are unable to process AMEX payments

Incident Report for Lightspeed - Status Page

Update

We are currently investigating the issue.
Posted Sep 09, 2026 - 03:03 EDT

Investigating

We have received reports that some CA merchants have been unable to process AMEX transactions since 4 September 2026 due to the payment method being disabled in error. Our team is actively investigating the issue, and we will provide further updates as soon as possible.
Posted Sep 09, 2026 - 00:16 EDT
This incident affects: Lightspeed Restaurant (K-Series) (Lightspeed Payments).