Get email notifications whenever Lightspeed - Status Page creates, updates or resolves an incident.
Get text message notifications whenever Lightspeed - Status Page creates or resolves an incident.
Get webhook notifications whenever Lightspeed - Status Page creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 04, 2024 - 23:00 EST
Scheduled
We're excited to announce another update to your POS that will bring improved efficiency and stability.
Update Time: Tuesday, November 5 at 15:00 AEDT Update Process: No need to interrupt your sales. Your POS will automatically update after 15:00 AEDT.
We’re releasing a small update to improve system performance and internal integrations. This has no impact on customer-facing features or functionality.
IN CASE YOU MISSED IT Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral! See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Nov 04, 2024 - 22:50 EST
This scheduled maintenance affected: Lightspeed Restaurant (O-Series) (POS, Back Office).