Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 05, 2025 - 01:00 EDT
Scheduled
We're excited to announce another update to your POS that will bring improved efficiency and stability.
Update Time: Tuesday, August 5 at 15:00 AEST Update Process: No need to interrupt your sales. Your POS will automatically update after 15:00 AEST.
NEW - The POS will now auto-refresh once daily to help maintain stability and ensure the app reflects the latest updates without manual intervention.
IMPROVED - Ongoing performance optimisations have been made across the POS, including improvements to PIN entry, the Tables screen, and image loading.
RESOLVED - Lite plans can now be activated correctly when trialling the Purchase, Produce, or Insights add-ons. - Newly assigned Lightspeed Payments terminals now appear immediately after refreshing the terminal list. - Pay at Table now correctly includes service charges in totals and displays receipts that match your POS.
IN CASE YOU MISSED IT Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral! See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Jul 31, 2025 - 00:29 EDT
This scheduled maintenance affected: Lightspeed Restaurant (O-Series) (POS, Back Office).