Lightspeed Restaurant (O-Series) - Updates & New Improvements 12.18.0

Scheduled for Sep 29, 01:00 - 02:00 EDT

Scheduled

Update Time: Tuesday, September 29 at 15:00 AEST
Update Process: Your POS will automatically update after 15:00 AEST.

NEW
- The new Orders screen in POS shows which orders are due soon, so your team can see what needs attention. You can opt in and switch back to the current screen at any time.

IMPROVED
- On-account invoices sent by email now show the full sale number, making it easier to match each invoice to the right sale.
- Back Office Purchase reports now load more reliably when you filter by category and tag.

RESOLVED
- Fixed an issue where retrying a Lightspeed Payments transaction while it was still processing could start a second payment.
- Fixed an issue where POS could stay locked after a refund in Local mode if the payment terminal did not respond.
- Fixed an issue where Back Office asked customers on legacy annual plans to upgrade.

MORE PRODUCT UPDATES
For the latest feature announcements, visit Lightspeed Product Updates.

IN CASE YOU MISSED IT
Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral!
See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Sep 23, 2026 - 02:24 EDT
This scheduled maintenance affects: Lightspeed Restaurant (O-Series) (POS, Back Office).