Unable to complete sales

Incident Report for Lightspeed - Status Page

Resolved

We are receiving reports from merchants that they are able to complete sales again. This incident has been resolved. Sorry for any inconvenience this may have caused you.
Posted Sep 27, 2023 - 20:09 EDT

Monitoring

A fix has been implemented. Affected merchants might need to refresh the sales screen.
Posted Sep 27, 2023 - 19:57 EDT

Investigating

We are getting reports of merchants experiencing issues completing sales. A fix is already being prepared.
Posted Sep 27, 2023 - 19:47 EDT
This incident affected: Lightspeed Retail (X-Series) (Retail POS).