Degraded performance of integrated payment processing
Incident Report for Lightspeed - Status Page
Resolved
Integrated payment processing has now returned to normal
Posted May 06, 2022 - 12:39 EDT
Identified
Our payment processing partners have identified the issue and are working on a resolution
Posted May 06, 2022 - 11:41 EDT
Investigating
We have identified an issue where Lightspeed Payments and Worldpay transactions on Lightspeed Retail (R Series) is experiencing degraded performance and lower approval rates. Team is currently investigating the issue
Posted May 06, 2022 - 11:03 EDT
This incident affected: Lightspeed Retail (R-Series) (Integrated Payments) and Lightspeed Restaurant (K-Series) (Lightspeed Payments).