We're excited to announce another update to your POS that will bring improved efficiency and stability.
Update Time: Tuesday, July 1 at 15:00 AEST Update Process: No need to interrupt your sales. Your POS will automatically update after 15:00 AEST.
IMPROVED - Lightspeed Payments terminals now pair more reliably, even when the POS and terminal are on different networks. - Several performance improvements have been made to enhance POS responsiveness during common actions.
RESOLVED - A bug affecting daily resets of online order prep times has been fixed to ensure consistent behaviour.
IN CASE YOU MISSED IT Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral! See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Jun 30, 2025 - 03:07 EDT
This scheduled maintenance affects: Lightspeed Restaurant (O-Series) (POS, Back Office).